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[bookmark: _Toc484079014]Using this Guide
[bookmark: _Toc484079015]Who should use this guide
This guide is intended for call takers, dispatchers, supervisors or anyone engaged in emergency communications in a Public Safety Answering Point (PSAP), security, or safety/operations command center type environment. Although Call Taker SoftPhone is intuitive and easy to learn, this guide will serve as a reference for on-screen controls and system operation.
[bookmark: _Toc484079016]Background 
The Call Taker SoftPhone, herein after known as Call Taker SoftPhone, represents state of the art technology that provides emergency services call center professionals access to advanced telephony controls and features via a customizable desktop PC interface. Call Taker SoftPhone is a MicroAutomation Emergency services product based on the CallCenter Millennium product family. The Call Taker SoftPhone user interface was designed taking into account the emergency call taker’s need for maximum flexibility and convenience in call handling. The advanced touch-screen controls and sophisticated features place all necessary tools at the user’s fingertips, allowing emergency operators to be more efficient.
[bookmark: _Toc484079017]Scope
This document provides step by step instructions for accessing and using Call Taker SoftPhone for anyone approved for its use in emergency call center operations centers. 



[bookmark: _Toc484079018]Acronyms and Conventions
Figure 1.1 lists acronyms and abbreviations of terms used in this document.
	Acronym
	Definition

	ANI
	Automatic Number Identifier. A feature of a telecommunications network for automatically determining the origination telephone number on calls for billing purposes. Not to be confused with caller ID service.

	ALI
	Automatic Location Identifier. The automatic display at the PSAP of the
telephone number, the address/location and supplementary emergency
services information of the location from which a call originates.

	CAD
	Computer-Assisted Dispatch. A method of dispatching taxicabs, couriers, field service technicians, mass transit vehicles or emergency services assisted by computer.

	CBN
	Call Back Number. The Call Taker will obtain the basic information from the caller. At a minimum, this information should include: the location of the incident, call back number, type of emergency, time frame, hazards, identity of those involved and their location.

	CAMA
	CAMA (Centralized Automatic Message Accounting) line. An analog trunk, usually Pulse driven circuits, connected to a Tandem Office, dedicated to delivering 9-1-1 calls to PSAPs.

	PANI
	Pseudo-Automatic Number Identifier. A 10-digit number used to identify the location of a wireless caller by cell site/sector or a specific wireless E911 call.

	PSAP
	Public Safety Answering Point

	SMS
	Short Message Service

	TDD
	Telecommunications Device for the Deaf

	VPN
	Virtual Private Network


[bookmark: _Toc479413251][bookmark: _Toc484078930]Figure 1.1 Acronyms and Abbreviations

Figure 1.2 lists the publication conventions used in this guide. 
	Convention
	Usage

	[bookmark: _Hlk482012130]Arrow ()
	Denotes a one-step procedure

	Click or Double Click – Windows
Tap or Double Tap – Touchscreen
	Denotes a mouse click (for regular Windows environments). If the user is in a Touch Screen environment, a Tap or Double Tap action would be used in place of the click procedure described.

	Blue Underscored Text
	Used for active links

	Boldface
	Used for:
· Button names
· Link names
· Tab names


[bookmark: _Toc484078931]Figure 1.2 Publication Conventions

[bookmark: _Toc484079019]Online User Guide
An online version of the Call Taker SoftPhone User Guide can be accessed whether a user is logged into the system or not. 
A user logged into Call Taker SoftPhone can access the electronic user guide through the Help pulldown by clicking on the Help pulldown menu and selecting the View Help option.
	[image: ]

	[bookmark: _Toc484078932]Figure 2.1 Call Taker SoftPhone User Guide access menu



To access the Help File without being logged in, right click on the Call Taker SoftPhone Desktop Icon and choose Properties. The Call Taker SoftPhone Properties window will open. Click on the “Open File Location” button, which opens a Windows Explorer window presenting the Call Taker SoftPhone Installation Directory. Double click on the file named help, and the Call Taker SoftPhone User Guide, shown in Figure 2.2, will open. 
Once the Help File is opened, the following window will appear:
	[image: ]

	[bookmark: _Toc484078933]Figure 2.2 Call Taker SoftPhone Online User Guide


Clicking on any of the blue links will automatically take the User to that section of the User Guide.
[bookmark: _Toc484079020]Launching Application
Note: If you are using Virtual Private Network (VPN) software to access a network, be sure to launch it first and verify that it is working before attempting to access Call Taker SoftPhone.
A user can launch the Call Taker SoftPhone application by either:
· Double-clicking on the desktop icon shown in Figure 3.1 or
· Open the Start menu, locate and launch the Call Taker SoftPhone application.

	[image: ]

	[bookmark: _Ref483668552][bookmark: _Toc484078934]Figure 3.1 Call Taker SoftPhone Desktop Icon



[bookmark: _Hlk482024280]The System Administrator may have configured the system for “Omni911 Named User Authentication”, “Integrated Windows Security”, or “No User Authentication”. Based on the configuration the following sections describe the expected behavior. Refer to the section titled “Call Taker (User) Authentication” for additional information.

[bookmark: _Toc484079021]Named User Authentication
If Call Taker SoftPhone is configured to accept Named User authentication, the following dialog box will appear:
	[image: ]

	[bookmark: _Toc484078935]Figure 3.2 Call Taker SoftPhone User Login Dialog Box



The user will then enter their User ID and password and click OK to access the system.
[bookmark: _Toc484079022]Integrated Windows Security Authentication (SSO)
If Call Taker SoftPhone is configured to accept Integrated Windows Security (single sign-on) authentication, the user will not be presented with an application logon. The application will use the Windows network credentials to authenticate the user. If the Windows user is not configured as a user of the application, they will receive a failed authentication message.
	[image: ]

	[bookmark: _Toc484078936]Figure 3.3 Call Taker SoftPhone Failed Windows Authentication


Note: Users receiving a failed authentication message will have to contact the System Administrator in order to have their Windows network credentials added into the application.
[bookmark: _Toc484079023]No User Authentication
If Call Taker SoftPhone is configured for No User authentication, it assumes that any user who successfully logs into the machine is authorized to use the application. The application doesn’t perform authentication protocols, therefore the user will not be prompted to log into the system.

[bookmark: _Toc484079024]Log Out
A user logging off of Call Taker SoftPhone can log off the system by clicking on the “File” menu and choosing “Exit.” 
Call Taker SoftPhone will automatically shut down.
	[image: ]

	[bookmark: _Toc484078937]Figure 3.4 Exiting Call Taker SoftPhone



Note: If you are using Virtual Private Network (VPN) software to access a network, remember to disconnect after logging off of Call Taker SoftPhone.

[bookmark: _Toc484079025]Forgotten Password
Users who have forgotten their password will have to contact either the Network Administrator (Integrated Windows Security) or the System Administrator (Call Taker SoftPhone Named User Authentication), to request a reset.

[bookmark: _Toc484079026]Using Call Taker SoftPhone
Call Taker SoftPhone is designed to run in Windows environments, and is compatible with 
Windows 7, 8 and 10. In addition, it is optimized for use with touchscreen displays, and while touchscreen environments are recommended, its features can be accessed using a traditional mouse and or pointing device. When a physical keyboard is not available in a touchscreen environment, a Windows touch screen keyboard can be enabled to allow users to type their input.
The Call Taker SoftPhone user interface is completely customizable, and has many standard and optional features that are available based on the package purchased and the options that are configured by your company’s System Administrator. 
This section will cover all of Call Taker SoftPhone’s features, including its configuration settings, the functionality of each window, and how to manipulate and configure layouts, both docked and undocked. This will be done using selections from the Options and Windows pull down menus. Your installation will vary based on the options that were purchased and how Call Taker SoftPhone is configured by your administrator. 
[bookmark: _Toc484079027]Audio/Video Configuration
The Call Taker SoftPhone application’s Configuration menu gives the user the ability to establish how it operates with the computer audio and video devices and sound files it is designed to interface with.  
Selecting Options > Configuration presents the Configuration window and current settings, in 3 sections. 
The Voice over Internet Protocol (VoIP) Section allows the user to make selections for their Output Device, Input Device and Video Device using the selections available in the pulldown menus shown:
	[image: ]

	[bookmark: _Toc484078938]Figure 4.1 Configuration: VoIP Selections






The Reorder Playback Section allows the user to select the Device that a recorded conversation can be played back on using the selections available in the pulldown menu:
	[image: ]

	[bookmark: _Toc484078939]Figure 4.2 Configuration: Recorder Playback Selection



The Alerting Section gives the user the ability to set a Device, choose Emergency, Non-Emergency, Chat/SMS, Auto Answer Emergency, and Auto Answer Non-Emergency tones based on the nature of the alert, and set the Alert Volume when Idle and Alert Volume when Active using the selections available when using the pulldown, up/down arrows and ellipsis menus:
	[image: ]

	[bookmark: _Toc484078940]Figure 4.3 Configuration: Alerting Section



Note: Any and all changes made in the Configuration menu will require a restart of the Call Taker SoftPhone application in order for the changes to take effect. 

[bookmark: _Toc484079028]User Interface: Main Window
The Call Taker SoftPhone User Interface is made up of a Main Window and Application Windows or Panels. The Main Window serves as the place where the Application Windows are arranged as panels, and either locked in place or “docked” in a permanently arranged state or allowed to float freely according to the user’s needs and preferences. In Figure 4.5, the Main Window is shown with Application Panels arranged on top and locked in place.
	[image: ]

	[bookmark: _Toc484078941]Figure 4.4 Main Window Without Application Panels


 
	[image: ]

	[bookmark: _Ref483317573][bookmark: _Toc484078942]Figure 4.5 Main Window with Application Panels



[bookmark: _Toc476145218][bookmark: _Toc484079029]Scrolling Ticker and Status Bar

Additional features found on the Main Window include the Scrolling Ticker and Status Bar, shown below: 
	[image: ]

	[bookmark: _Toc484078943]Figure 4.6 Scrolling Ticker and Status Bar



The status indicator on the left side of the Status Bar displays the application initialization status. “Loading” is displayed immediately following the launch of the Call Taker SoftPhone application. “Ready” is displayed once the application has completed its initialization. A display of “Ready – using cache” indicates the application was not able to acquire its configuration from the Call Taker SoftPhone Communications Server and is using a previously acquired configuration which was locally preserved. If this occurs, the application is ready and usable; however, users should contact your organization’s System Administrator or support provider for troubleshooting assistance.
The status indicators on the right side of the Status Bar display the system’s communication link status with the Call Taker SoftPhone Communications Server and the CTI Server (optionally installed). These indicators are color coded: Green indicates an active communication link to the server; where Red indicates the communication link is experiencing challenges. In the event of a Red communication link status indicator, the application may still receive telephone calls; but will lack functionality provided by the noted communication link. Contact your System Administrator or support provider for troubleshooting. 
Other indicators displayed on the right side of the Status Bar include the Call Taker Station ID, whose configuration was loaded at application initialization; and the current Time.


 
[bookmark: _Toc484079030]Main Window Options
Users wishing to make adjustments to the Main Window can do so by using the Options pulldown menu.
	[image: ]

	[bookmark: _Toc484078944]Figure 4.7 Main Window Options Menu



This menu allows users to make adjustments to the screen size, the font size the layout, and the color theme. 
FullScreen

The FullScreen menu gives the user the option to expand the size of the Main Window, so that there is more space to add application. Users wishing to make this adjustment should select Options>FullScreen (Shown in Figure 4.8). 
	[image: ]

	[bookmark: _Ref483318667][bookmark: _Toc484078945]Figure 4.8 FullScreen Main Window Options Menu






Font Size
The application’s text size can be increased and decreased by selecting Options > Font Size, and choosing from the Increase, Decrease and Reset options.
	[image: ]

	[bookmark: _Toc484078946]Figure 4.9 Font Size Main Window Options Menu



[bookmark: _Toc484079031]User Interface: Application Windows
Call Taker SoftPhone features are accessible via application windows which may be docked as a panel in the application’s Main Window or configured as a floating window. When docked a panel can be moved, reorganized, or resized.
The following figure displays the application’s Main Window with commonly used windows which have been docked, sized, and arranged to create a personalized layout.
	[image: ]

	[bookmark: _Toc484078947]Figure 4.10 Main Layout with Application Windows



The following sections describe the functionality of each Call Taker SoftPhone window and refer to each window as a docked panel.
[bookmark: _Toc484079032]Alert 
The Alert Panel (shown below) communicates the current status of the Call Taker station and promotes an alert when a new incoming Phone Call or Chat/SMS request is received. Various animations and colors are displayed based on whether the Call Taker station is Idle, Active on a call, or in a Chat/SMS conversation when receiving a new incoming Phone Call or Chat/SMS request.
	[image: ]

	[bookmark: _Toc484078948]Figure 4.11 Alert Panel - Idle State



The Call Taker station is considered Idle when it is not engaged in a Phone Call or Chat/SMS conversation. Clicking on the panel has no effect.
The Call Taker station is considered Active when it is engaged in a Phone Call or Chat/SMS conversation. Clicking on the panel has no effect.
	[image: ][image: ][image: ]

	[bookmark: _Toc484078949]Figure 4.12 Alert Panel in the Active State for Call, Chat, SMS



Phone Call – In Progress 
While in one or more Phone Calls, the Alert panel background displays a green color and contains an image of a Phone, as shown in the left image above.
Chat/SMS – In Progress
While in one or more Chat/SMS conversation, the Alert panel background displays a green color and contains an image of a Chat/SMS caption, as shown in the middle image.
Phone Call AND Chat/SMS – In Progress
While in both a Phone Call and a Chat/SMS conversation, the Alert panel background displays a green color and contains an image of a Phone and a Chat/SMS caption, as shown in the right image.
The Call Taker station is considered Alerting when an incoming Phone Call or Chat/SMS request is received. Clicking on the panel when there is an incoming Phone Call or Chat/SMS request will answer the call or accept the Chat/SMS request.
	[image: ][image: ]

	[bookmark: _Toc484078950]Figure 4.13 Call Taker SoftPhone Alert Panel - Alerting State



Phone Call - Alerting
When Call Taker SoftPhone receives an incoming phone call, the Alert Panel image will flash Red. 
Chat/SMS Request - Alerting
When Call Taker SoftPhone receives an incoming Chat/SMS request, the Alert Panel image will flash Yellow.
If the Call Taker station was Idle (not engaged in a Phone Call or Chat/SMS conversation) when it begins alerting, the Alert panel will continue to display its panel default background color and will not contain an image of a Phone and/or Chat/SMS image
If the Call Taker station was Active (engaged in a Phone Call and/or Chat/SMS conversation) when it begins alerting, the Alert panel will continue to display a green background and contain an image of a Phone and/or Chat/SMS image.
[bookmark: _Toc484079033]Lines
The Lines panel displays buttons representing all the configured phone lines available on the Call Taker’s station. The lines available will vary for each implementation, and is configured by the System Administrator. 
The Lines typically included in the Call Taker SoftPhone package are shown below:



External Emergency Line – The External Emergency Line is represented by the picture shown below. Callers dialing the national emergency telephone number (911) and are seeking police, fire, or emergency services will come through these lines. These calls are delivered from the local telephone company switch on a special 911 circuit. These lines are designed to accept inbound calls only.
	[image: ]

	[bookmark: _Ref483844104][bookmark: _Toc484078951]Figure 4.14 Call Taker SoftPhone External Emergency Lines



In Figure 4.14, the picture represents the line in an idle state. In the upper right corner is a box which displays a background color and an icon to indicate the type of line.  During an incoming call, the ringing line will highlight in Blue and a box will appear in the upper left corner that will display background colors designed to indicate the state of the phone line (ringing, active, on-hold). The box also includes a timer that shows the duration of the call in the current state. Active states for External Emergency lines are depicted in Figure 4.15

	[image: ]

	[bookmark: _Ref484008830][bookmark: _Toc484078952]Figure 4.15 Call Taker SoftPhone External Emergency Call Active States



Red indicates that there is an incoming call, Dark Green indicates that the line has been selected and the call is active, and Yellow indicates that the call is on hold. In the lower right corner is the line button’s Name (ie. CAMA 1) followed by the caller’s ANI. 

Internal Emergency Line - Callers in a campus environment who are seeking police, fire or emergency services provided by the campus would dial a number specifically designated for that campus environment. These calls could be routed either from the local telephone company switch on a non-911 circuit, or from the campus/company telephone switch (if dialed from a campus/company phone). These lines are designed to accept inbound calls only.
	[image: ]

	[bookmark: _Ref484008913][bookmark: _Toc484078953]Figure 4.16 Call Taker SoftPhone Internal Emergency Lines





	[image: ]

	[bookmark: _Ref484008954][bookmark: _Toc484078954]Figure 4.17 Call Taker SoftPhone Internal Lines Active States



In Figure 4.16, the picture represents the line in an idle state. In the upper right corner is a box which displays a background color and an icon to indicate the type of line.  During an incoming call, the ringing line will highlight in Blue and a box will appear in the upper left corner that will display background colors designed to indicate the state of the phone line (ringing, active, on-hold). The box also includes a timer that shows the duration of the call in the current state. Active states for External Emergency lines are depicted in Figure 4.17.

Red indicates that there is an incoming call, Dark Green indicates that the call is active, and Yellow indicates that the call is on hold. In the lower right corner is the line button’s Name (ie. Campus 1) followed by the caller’s ANI. 

Non-Emergency Line – Callers in a campus/company environment who are seeking non-emergency or administrative services provided by the campus/company would dial a number specifically designed for that environment. These calls could be delivered from the local telephone company switch on an non-911 circuit, or from the campus/company telephone switch (if dialed from a campus/company phone). These lines are designed to accept inbound calls only, represented by the middle image.
	[image: ]

	[bookmark: _Ref484074256][bookmark: _Toc484078955]Figure 4.18 Call Taker SoftPhone Non-Emergency Lines






Personal Callback Line – Operators in a campus or call center environment could either receive incoming calls from callers dialing a specific extension tied to the station or make outbound calls in order to provide follow-up assistance to previous inbound callers using the Personal Callback Line, shown in Figure 4.19.

	[image: ]

	[bookmark: _Ref483842172][bookmark: _Toc484078956]Figure 4.19 Call Taker SoftPhone Personal Callback Lines



In Figure 4.19, the picture represents the line in an idle state. In the upper right corner is a box which displays a background color and an icon to indicate the type of line.  
	[image: ]

	[bookmark: _Ref484010702][bookmark: _Toc484078957]Figure 4.20 Call Taker SoftPhone Personal Callback Lines Active States



During incoming and outgoing calls, the ringing line will highlight in Blue and a box will appear in the upper left corner that will display background colors designed to indicate the state of the phone line (ringing, active, on-hold). The box also includes a timer that shows the duration of the call in the current state. Active states for External Emergency lines are depicted in Figure 4.20.
In addition, the Non-Emergency and Personal Callback lines are designed to receive voicemails. A Gray square with an envelope in the Blue Admin line (Figure 4.18) indicates the presence of a voice message, and users can listen to the message by clicking on the line. After the message is heard, the line will return to the idle state.





Personal Conference Room Line – This line is designed to allow a Call Taker to coordinate conference call activities with incoming callers and other call takers and or support personnel. This line is designed only for conference call activities, and callers can only be added to or removed from the conference room by dragging and dropping the caller and or call taker into the room.
When callers are added to the Conference Room, a green box will appear in the upper left corner, and a Conference Panel will open, as shown in Figure 4.22.
	[image: ]

	[bookmark: _Toc484078958]Figure 4.21 Call Taker SoftPhone Personal Conference Room Line



The Conference Room Panel allows the Call Taker coordinating Conference Room activities to see who is on the call, and to control their activities. The information contained in the panel includes the ANI, Name and Role of the parties in attendance. The Call Taker also has the ability to Mute and Remove anyone on the call.
	[image: ]

	[bookmark: _Ref484075222][bookmark: _Toc484078959]Figure 4.22 Call Taker SoftPhone Conference Room Panel



In call center environments, configurations may call for and include Shared Lines. This arrangement will allow multiple stations to share lines and calls. A Shared Line will ring on multiple stations and may be answered by any operator at any station sharing the line. The line state is displayed on all stations, and allows a call to be placed on either private or public hold. Calls placed on public hold can be picked-up and an active call can be retrieved at any time by an operator at another station sharing the line.



[bookmark: _Toc484079034]Line Controls
The Line Controls panel is designed to be used interactively with the Lines and Dial Pad panels in order to process incoming and outgoing calls. This panel displays call handling buttons that are designed to be used with all of the phone lines displayed in the Lines panel. 
	[image: ]

	[bookmark: _Toc484078960]Figure 4.23 Call Taker SoftPhone Line Controls Panel


The list below describes how each of the buttons are designed to work with the lines that are available. Click on the button or buttons desired to manage call activity. 
· Dial – Using the first available personal line, this button dials the number displayed in the entry window of the Dial Pad as long as you are not in an active call.
· Answer – This button answers the oldest incoming call. (This button only works when there is an incoming call.)
· Mute – Selecting this button will mute microphone audio only on the station where mute is activated.
· Hold Call (Public) – Selecting this button places the call on/off of public hold. While on public hold the call may be retrieved by any active client workstation that shares the line the call is on.
· Hold Call (Private) – Selecting this button places the active call on/off of private hold. The call may only be managed by the operator on the workstation where the call is on hold.
· Blind Transfer Active Call – Choosing Blind Transfer places the active call on private hold and allows the operator to dial the number displayed in the entry window of the Dial Pad and immediately transfer the call to the dialed number.
· Consult Transfer Active Call – Choosing Consult Transfer puts the active call on private hold, allowing the operator to dial the number he/she desires to transfer the call to in the entry window of the Dial Pad. Once the other party answers, press Transfer again to complete the action. Pressing Release prior to pressing Transfer the second time will release the other party without transferring the call, allowing the original operator to return to the active call.
· Conference Active Call – Choosing Conference Active Call puts the active call on private hold, allowing the operator to dials the number of the party desired (which will be displayed in the entry window of the Dial Pad). Once other party answers, pressing Conference again will complete the conference and all three parties can talk to each other. Clicking or tapping Release prior to Clicking or tapping Conference the second time will release the other party without creating the conference and return to the active call.
· Park – Selecting Park moves the active call and adds it to the Parked Calls panel. Parked calls may be retrieved or answered by selecting the call. 
· Release – Selecting Release disconnects the active call. (This only works when there is an active call.)

[bookmark: _Toc484079035]Dial Pad

The Dial Pad functions similar to a traditional telephone keypad and is used to make a call by dialing an internal extension or an external telephone number.
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	[bookmark: _Toc484078961]Figure 4.24 Call Taker SoftPhone Dial Pad Panel



The list below describes how each of the buttons are designed to work with the lines that are available. Click on the button or buttons desired to manage call activity. 
· Entry Window - The entry window (shown as a blank field in the Dial Pad) allows free-form number entry via the Dial Pad, as well as selecting recently dialed numbers from the drop-down list, represented by the down arrow.
· Dial Pad – The numeric keypad shown in Figure 3.20 is used to make phone calls. This is done by Clicking on Flash and then the appropriate phone or extension numbers and pressing Enter. Those numbers will appear in the entry window. While being connected to a call, the numeric digits will produce the appropriate tones used by standard telephones.
· Hook Flash – Functions as a hook flash which may be used for some transfer functions depending on system configuration.
· Clear Entry – Clears all the content in entry window.
· Delete – Deletes a character in the entry window.

[bookmark: _Toc484079036]Telecommunications Device for the Deaf

Call Taker SoftPhone gives call takers the ability to communicate with callers who use Telecommunications Device for the Deaf (TDD) units when reaching out for emergency services. The TDD Conversation window shown in Figure 4.23 displays an active conversation between the call taker and party receiving support via a TDD device.
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	[bookmark: _Ref483853459][bookmark: _Toc484078962]Figure 4.25 Call Taker SoftPhone TDD Control Panel



The TDD Conversation Window includes pre-programmed message buttons that provide one-touch common response phrases during an interaction with an outside party. Button labels and response text may be customized by the System Administrator.
The list below describes how each of the buttons in the TDD panel are designed to work when an operator is interacting with a party needing assistance. Clicking on the button or buttons desired will allow Call Takers to effectively manage communications activity. 
· Clear Display - Clears the messages from the TDD message area
· Copy to Clipboard – Copies the current conversation to the clipboard
· TDD Conversation Window - Displays the conversation between the caller and the call taker in contrasting text colors
· Pre-Programmed Message Buttons – Buttons send pre-defined, common messages with a single click. Messages and button labels are defined by the System Administrator
· Caller Responses –Messages from callers are displayed in message area
· Call Taker Responses – Messages from the call taker are displayed in the message area
· Send to CAD – Send the conversation to an integrated CAD application for archival. This button may not be present if not included in the system’s configuration.
· Print – Print the conversation to the Windows default printer.

[bookmark: _Toc484079037]Video
Call Taker SoftPhone has the ability manage video feeds placed by customers seeking assistance. 
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	[bookmark: _Toc484078963]Figure 4.26 Call Taker SoftPhone Remote/Local Video Panels



The Remote and Local Video panels display videos (when video is available) that are associated with an active call when the remote caller is calling with a cell phone that has a camera. The Local Video panel presents video sent via the Call Taker’s camera at their workstation.
· Remote Video Feed – Displays video from the caller’s cellphone camera
· Local Video Feed – Displays live video from the Call Taker’s workstation camera 



[bookmark: _Toc484079038]Chat/SMS

The Chat/SMS panel displays a list of active Chat and/or SMS conversations. A Chat is a conversation that occurs between two Call Taker’s within a call center environment. An SMS is a conversation that involves a Call Taker within a call center environment and an external party who wishes to receive support.
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	[bookmark: _Toc484078964]Figure 4.27 Call Taker SoftPhone Chat/SMS Panel



The list below describes how each of the fields and buttons in the Chat/SMS panel are designed to work when a Call Taker is interacting either internally with another Call Taker or with an external party needing assistance. Click on the button or buttons desired to establish and manage communications activity. 
· ANI – The phone number associated with either an Call Taker SoftPhone Station or the party receiving support
· Type of Chat – This can either be Station or SMS 
· Request ALI – Displays ALI information in the ALI panel for the selected Chat/SMS Conversation
· Time – The time the Chat/SMS Conversation began
· State – The state of the Chat/SMS Conversation (Alerting or Accepted)
· Owner – The station that currently owns the Chat/SMS Conversation (either Alerting or Accepted)
· Accept – Accepts the oldest Alerting Chat/SMS Conversation. If you want to accept a newer Chat/SMS Conversation, Double-Click the row where the Chat/SMS Conversation is displayed. 
· Reject – Rejects the selected Chat/SMS Conversation
· New Chat – Start a new Chat/SMS Conversation

Clicking the Accept button accepts the oldest Chat/SMS conversation in an Alerting state, and opens a Chat/SMS Conversation window. 
Selecting a conversation in the list with an Alerting state, and clicking the Reject button, rejects the selected conversation. A rejected Chat conversation will merely notify the requesting Call Taker’s station of the rejection, while a rejected SMS conversation will be re-routed to another Call Taker.
Selecting any conversation in the list and clicking the ALI button will display its ALI information (when available) within the ALI display panel.
Clicking the New button presents the New Chat/SMS window to determine the type of chat (SMS or Station), the sender, and the receiver for the new conversation. 
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	[bookmark: _Toc484078965]Figure 4.28 Call Taker SoftPhone Create Chat Window



The list below describes how each of the pull down menus and fields in the Create Chat Window panel are designed to work when a Call Taker is interacting either internally with another Call Taker or with an external party needing assistance. Click on the pull down menus and fields desired to establish and manage communications activity and select OK to establish or Cancel to cancel the activity.
· Type – The type of chat (Station or SMS)
· From – The originating Station ID for a Chat Conversation, or originating SMS number associated with the Call Taker SoftPhone service
· To – The receiving Station ID for a Chat Conversation, or receiving SMS number of the party receiving support

Clicking the OK button opens the Chat/SMS Conversation window.


[bookmark: _Toc476145229][bookmark: _Toc484079039]Chat/SMS Conversation 

The Chat/SMS Conversation Window displays an active conversation between the call taker and party receiving support via SMS (texting), or an active conversation between two Call Taker stations. The Chat/SMS Conversation window includes pre-programmed message buttons that provide one-touch common response phrases. Button labels and response text may be customized by the System Administrator. Click on the button or buttons desired to establish and manage communications activity. 
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	[bookmark: _Toc484078966]Figure 4.29 Call Taker SoftPhone Chat/SMS Conversation Window



· Copy to Clipboard – Copies the current conversation to the clipboard
· Print – Print the conversation to the Windows default printer
· Send To CAD – Send the conversation to an integrated CAD application for archival.  This button may not be present if not configured in the system configuration.
· Dialog Complete – Ends the current conversation
· Line – Line on which the conversation was received
· Call Taker Responses – Messages from the call taker displayed in black in Message area
· Dialog Box – The call taker can type their messages into this box
· Pre-Programmed Message Buttons – Buttons send pre-defined, common messages with a single click. Messages and button labels are defined by the System Administrator
· ANI – The phone number associated with either a Call Taker Station or the party receiving support

[bookmark: _Toc484079040]ACD Functions 
In instances when Contact Center (ACD) functionality is available, users must login before they can receive calls or chats. After login, the ACD Functions panel displays the current status of the agent. 
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	[bookmark: _Toc484078967]Figure 4.30 Call Taker SoftPhone ACD Functions Panel



The Logon and Logoff buttons in the first row can be used to log in and out of the workstation. The status indicator in the center displays the current status with “LOF” being logged off and “LON” being logged on. The “IN” button marks the agent as available to receive calls and the “OUT” button marks the agent as away and will not receive any calls. The dropdown arrow allows agents to select a reason for being away (Lunch, Break, etc.) 
Note: The status indicator or away dropdown arrow may not be shown depending on the configuration as defined by the System Administrator.
After the “Log On” button is selected agents will be prompted to enter their ID in order to log on.
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	[bookmark: _Toc484078968]Figure 4.31 Call Taker SoftPhone Agent ID Window






[bookmark: _Toc484079041]ANI/ALI
The Automatic Location Identifier (ALI) panel (shown below in Figure 4.30) displays location information about the caller that is available at the time it is retrieved from an ALI database. The ANI field can be used by a call taker to display the ALI information of recent calls by either selecting a recent call using the drop-down arrow or typing a phone number into it and clicking or tapping Rebid. The information is displayed exactly as received from the data source within the applicable fields. Any empty fields are a result of data that is not found in the ALI data source, and thus cannot be displayed.
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	[bookmark: _Ref483323425][bookmark: _Toc484078969]Figure 4.32 Call Taker SoftPhone ANI/ALI Information Panel



ALI information is provided for all emergency call types including:
· Landline emergency calls
· Phase 1 Wireless 911 calls
· Phase 2 Wireless 911 calls
· VoIP 911 calls






The ANI/ALI panel contains 4 buttons in the upper right corner that give call takers additional functionality within the panel. They include:
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	[bookmark: _Ref483844725][bookmark: _Toc484078970]Figure 4.33 Call Taker SoftPhone ANI/ALI Functions



· Call Back – Represented by the first button in Figure 4.31. The Call Back button allows Call Takers to dial a call to the ANI represented in the field, directly from that panel.
· Rebid – The second button in the row allows call takers to retrieve the information for the current ANI from the ALI database.
· Clear – The button represented by the brush allows users to clear all of the fields in the panel. Using this button does not delete the data from the database.
· Submit Updates – This button, represented by the pen and paper, opens an editor, which allows call takers to add missing information to a caller’s record in the ALI database.

The Submit Updates button opens the ALI Editor (Figure 4.32), a panel that allows a call taker to update incorrect information into the ALI database. Any value can be changed by clicking on that value, typing in the correct information and clicking on OK.
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	[bookmark: _Ref483389443][bookmark: _Toc484078971]Figure 4.34 Call Taker SoftPhone ALI Editor



Landline Emergency Calls – Local ALI Data Source

ALI information for Landline Emergency calls is retrieved from one or more databases. The Call Taker SoftPhone system is configured by the System Administrator to retrieve ALI information from a local ALI database and/or from a regional database typically provided by a telephone carrier or ALI provider.
The following example shows ALI data for a local data source that utilizes only building/room type addressing and is commonly associated with a campus, compound, or base type facility.
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	[bookmark: _Toc484078972]Figure 4.35 Call Taker SoftPhone Local ALI Example



· ANI – Phone number of the caller
· Date/Time – Date and Time of the ALI request
· Call Back Number (CBN) – Call back number for the caller
· Name – Name of the caller as contained in the ALI record
· City/State – City and State of the caller location
· Bldg/Room (Location) – Building and Room information of the caller
· Raw ALI – Raw location information as received from the data source and before processing into appropriate data fields (Shown as the text field at the bottom of the panel)



Landline Emergency Calls – Remote ALI Data Source

ALI information for regional emergency calls is retrieved from remote local carrier ALI databases. The following example shows ALI data retrieved from a remote ALI database provided by a telephone carrier. Data is formatted into common street address fields as well as displayed in raw, unformatted data.
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	[bookmark: _Toc484078973]Figure 4.36 Call Taker SoftPhone Remote Ali Example



· Closest Police Station – Displays the closest police station
· Closest Fire Station – Displays the closest fire station
· Closest EMS/Ambulance – Displays the closest Ambulance service
· Class – Type classification of the received call, Commercial/Business or Residential location
· Source (CO ID) – Displays the name of the carrier name from which the information was retrieved



Phase 1 Wireless Calls

ALI for Phase 1 wireless calls is retrieved from a remote local carrier ALI database. The following example shows an ALI display for a typical Emergency call from a Phase-1 Wireless caller:
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	[bookmark: _Toc484078974]Figure 4.37 Call Taker SoftPhone Phase 1 Call Example



Phase-1 Wireless data includes the following additional fields:
· Cell Tower Latitude/Longitude/Elevation (X, Y, Z) – The coordinates of the cell tower through which the call was received
· Direction – The angle at which the caller was able to connect to the cell tower (Shown in the Address field)
· Pseudo ANI (PANI) – The PANI of the wireless caller. The PANI is then queried against the carrier database and displays available ALI data as well as actual ANI
· Class – The type classification WPH1 denotes wireless Phase 1 data
· Source (CO ID) – Carrier name from which the information was retrieved 



Phase 2 Wireless Calls

ALI information for Phase 2 calls is retrieved from the remote carrier ALI database. The following figure shows an example of ALI display for an Emergency call from a Phase-2 Wireless caller:
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	[bookmark: _Toc484078975]Figure 4.38 Call Taker SoftPhone Phase 2 Call Example



· Caller Latitude/Longitude/Elevation – The latitude, longitude and Elevation information of the caller as denoted by X, Y and Z coordinates
· Deviation – Deviation of the caller location from the coordinates is shown in the Meters field
· Confidence – The percentage accuracy of the coordinate location is reflected in the Percent field
· Class – The type classification WPH2 denotes wireless Phase 2 data



VoIP Calls

ALI information for VoIP calls is also retrieved via a remote carrier ALI database. The following figure depicts ALI display for an Emergency call received from a Voice over Internet Protocol (VoIP) caller:
	[image: ]

	[bookmark: _Toc484078976]Figure 4.39 Call Taker SoftPhone VOIP Call Example



Class – The type classification VOIP denotes a Voice over Internet Protocol call.


[bookmark: _Toc484079042]Active Calls

The Active Calls panel displays a list of all active calls, across all Call Taker stations. The panel displays the Station ID of the station handling each active call, as well as the call’s incoming line, ANI, Date/Time the call was received, and current State.
Selecting any active call in the list and Clicking the ALI button will display its ALI information (when available) within the ALI display panel.
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	[bookmark: _Toc484078977]Figure 4.40 Call Taker SoftPhone Active Calls Panel



· Station ID – Station Identifier of the station handling the call
· Line – Line on which the call was received
· Request ALI – Displays ALI information in the ALI panel for the selected call
· Call State – Current state of the call (Connected or On Hold)
· ANI – Phone number of the caller
· Time – Time the call began
· ALI – Raw ALI for the call
· Monitor – The line that is monitoring the call
The remaining four buttons are monitoring buttons which allow this Call Taker Softphone station to monitor the active call being processed on anther Call Taker Softphone station. These buttons will be greyed out until a call is active on the station.
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	[bookmark: _Toc484078978]Figure 4.41 Call Taker SoftPhone Monitoring Buttons



Clicking the Silent button starts a monitoring session where the monitoring party is silently in the background listening to the conversation of all parties on the call. No party on the active call can hear the monitoring party while in silent mode. 
Clicking the Whisper button changes the mode and allows the monitoring party to speak and be heard only by the call taker being monitored. If the monitoring party can join the conversation and engage with all parties on the call at any time. 
Clicking the Barge-In button creates a conference call for all parties involved in the call.
Clicking the Pickup button allows the Supervisor to pick up the call.
[bookmark: _Toc484079043]Parked Calls
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	[bookmark: _Toc484078979]Figure 4.42 Call Taker SoftPhone Parking Lot Panel



The Parked Calls panel displays a list of calls that are currently parked. It also shows the ANI, the Station ID which parked the call and the length of Time that a call has been parked. 
Selecting any parked call in the list and clicking the Retrieve button will remove the call from the list of parked calls and transfer it to your Call Taker SoftPhone workstation.



[bookmark: _Toc484079044]Call History

[bookmark: _Hlk481853892]The Call History panel displays a list of recent calls and chat dialogs, across all Call Taker SoftPhone stations. The panel displays the Station ID of the station which handled each call, as well as the call’s incoming Line, ANI, Date/Time the call was received, call Duration, Disposition, Callback Station, Call ID and Type. 
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	[bookmark: _Toc484078980]Figure 4.43 Call Taker SoftPhone Call History Panel



· Station – The Station ID number of the station handling the call
· Line– The Line on which the call was received
· Request ALI – Displays ALI information in the ALI panel for the selected call
· Call Back – Call back to the ANI for the selected call
· Time of call – The date/time at which the call was received
· Call Duration – Duration of the call
· ANI – Phone number of the caller
· Call Disposition – How the call was ended
· Callback Station – The station that called back the caller
· Call ID – Generated ID that represents the call
· Call Type – The type of call

Selecting any call in the list and clicking the ALI button will display its ALI information (when available) within the ALI display panel.
Selecting any call in the list and clicking the Callback button will initiate an outbound call (callback) using the ANI of the selected call.


[bookmark: _Toc484079045]Phonebook

The Phonebook panel displays a list of contacts, which includes the Icon, Name, Phone, Address, and Category. A description of the features in this panel is listed below:
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	[bookmark: _Toc484078981]Figure 4.44 Call Taker SoftPhone Phone Book Panel



· Icon – This field contains an image/symbol that was associated with the contact.
· Name – The field contains the name of the contact
· Phone – The field contains the phone number of the contact 
· Address – The field contains the address of the 
· Filter – Shown as an empty field where the user can enter text which will be used as filter criterial
· Category – The Category dropdown menu allows the user to select a category which will be used as filter criterial. In this graphic, the category selections would be All, Local and Counties. The Category dropdown menu is dynamically populated based on the category of all phonebook entries.
· Add Entry – Represented by the plus sign (+), this button allows Call Takers to add entries to their workstation specific phone book.

To make a call using the Phonebook, click to select a contact in the list. This action populates its phone number into the Dial Pad. Then click on the Line Control panel’s Dial button to make an outbound call to the contact’s phone number.

The System Administrator has the ability to create a contact list that is global and visible on all Call Taker stations. Administrator created contact lists cannot be edited by Call Takers, but Call Takers can make new entries at their stations that are only visible in that station using the Contact Editor, shown in Figure 4.43. A description of the fields in this editor is listed below:
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	[bookmark: _Ref483662322][bookmark: _Toc484078982]Figure 4.45 Call Taker SoftPhone Contact Editor



· Name – The name of the new contact
· Phone Number – The phone number of the new contact
· Tandem Transfer – The number used by Quick Dial to perform a carrier transfer
· Category – The category that the new contact will go into
· Address – The address of the new contact
· Browse – Browse local files for an icon
· Icon Preview – (Shown as an empty box) Shows the icon of the new contact when populated
· Save – Saves the new contact

New phonebook entries may be created from a Call Taker’s station by clicking the Add Entry button. The Contact Editor will open, and the Call Taker can then enter and save new contacts by tapping or clicking on the Save button. Contacts created from a Call Taker’s station are only visible on that station and may only be edited from the specific Call Taker station where the contact was added.
The designated System Administrator has the ability to create a category that could be assigned to phonebook entries managed by a particular Call Taker’s station. Selecting a category from the Category dropdown box will instantly filter the visible phonebook entries to include only those assigned to the selected category. 
Searching the phone book is done by typing any characters into the Filter field (where the word “Search” is shown), which will instantly filter phonebook entries according to the search parameters entered.
Select a contact in the list by clicking on it. This will automatically populate the Dial Pad with the contact’s phone number. Clicking on the Line Control panel’s Dial button will make an outbound call to the selected contact’s phone number.
[bookmark: _Toc484079046]Quick Dials

The Quick Dial panel displays icons with contact names to allow one-touch dialing or transfer (blind/tandem) to common destinations.
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	[bookmark: _Toc484078983]Figure 4.46 Call Taker SoftPhone Quick Dial Panel



Each button is labeled and will dial the saved extension or phone number associated with the button with a single click. Only the System Administrator has the ability to configure the programmable buttons. Note that the phone number or extension will not appear in the number entry field. 
To add a Quick Dial button simply drag and drop any Phone Book entry to the Quick Dial panel. To remove a button from Quick Dial, drag and drop it into the Trash Can‘[image: ]’ located at the top right of the Main Window (Doing this does not delete the phone book entry).  The Quick Dial buttons can also be rearranged by dragging and dropping them to the desired position on the panel.




[bookmark: _Toc484079047]Clock

The Clock panel (Figure 4.45) displays the current time at the Call Taker’s location in the 24-Hour format. It also displays the date in the Day of the week, Month, Day, Year format.
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	[bookmark: _Ref483662833][bookmark: _Toc484078984]Figure 4.47 Call Taker SoftPhone Clock Panel



[bookmark: _Toc484079048]Volume Control

The Volume Control (Figure 4.46) panel displays sliders for changing the volume and amount of noise the Call Taker’s microphone will pick up. It also includes check boxes to the right of each slider that allows the user to mute the caller or the call taker. A description of the features in this panel is listed below:
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	[bookmark: _Ref483662972][bookmark: _Toc484078985]Figure 4.48 Call Taker SoftPhone Volume Control



· Volume Slider – Changes the volume of caller
· Microphone Gain Slider – Changes the amount of sound picked up by the Call Taker’s microphone
· Volume Mute (checkbox) – Mutes the caller when checked
· Microphone Mute (checkbox) – Mutes the Call Taker when checked





[bookmark: _Toc484079049]Recorder

The Recorder panel (Figure 4.47) displays a recording history of calls received at the Call Taker SoftPhone workstation. A description of the features in this panel is listed below:
	[image: ]

	[bookmark: _Ref483663045][bookmark: _Toc484078986]Figure 4.49 Call Taker SoftPhone Recorder



· Call Duration – Duration of the call
· Call Start – Start time of the call recording
· Skip Backward (Double Left Arrow) – Skip to the previous recording
· Play (Large Right Arrow) – Play the selected recording
· Stop (Large Square) – Stops the current recording being played
· Skip forward (Double Right Arrow) – Skip to the next recording
· Delete – Deletes the selected recording
· Playback Time Scale – Display the time scale of the selected recording
· Recording ID – Recording ID assigned to each recording
· ANI – Phone number of the caller
· Call ID – Generated ID that represents the call
· ALI – Raw ALI information

Call recordings are stored to the local PC hard drive and are intended for quick playback of call audio during or after the call. Each recording displays the Start Time, Duration, Caller ID, Recording ID, Call ID, and ALI. Any recording listed may be selected and the audio controls include Play, Skip, Stop and delete. Right-clicking on any recording allows it to be saved as a .wav file to the local computer.

[bookmark: _Toc484079050]Docking and Screen Layout
The Call Taker SoftPhone Main Window is the foundation on which numerous dockable Panels or “sub-windows” can be independently controlled and organized into a “Layout” on the screen, similar to the one shown in Figure 4.48.
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	[bookmark: _Ref483663276][bookmark: _Toc484078987]Figure 4.50 Call Taker SoftPhone Layout



[bookmark: _Hlk481843855]The application is shipped with a “Default” layout which the Main Window loads when the application is launched for the first time after installation. Each time a user exits the application, the currently loaded named layout is remembered and loaded the next time the application is launched. A user may restore the “Default” layout or any layout they’ve saved, at any time, by selecting Options > Layout > Load Layout > and selecting from the list of layouts, as shown in Figure 4.49.
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	[bookmark: _Ref483663372][bookmark: _Ref483663353][bookmark: _Toc484078988]Figure 4.51 Call Taker SoftPhone Default Layout Menu





Each time the Call Taker application is launched, the Layout Movement feature is disabled. A user can modify a layout to suit their individual needs and preferences by using the Enable Layout Movement feature, shown in Figure 4.50.
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	[bookmark: _Ref483664705][bookmark: _Toc484078989]Figure 4.52 Call Taker Softphone Enable Layout Option


[bookmark: _Hlk481840617]If the Enable Layout Movement menu option on the Options menu is unchecked, all panels are locked and cannot be moved. Selecting the Enable Layout Movement menu option toggles (enables and disables) the feature, which is represented by a checkmark next to the menu option. When the feature is enabled, all panels within the layout are unlocked and may be resized, moved or rearranged within the Main Window as desired.
Major modifications (adding, deleting, or moving location of panels) made to the currently loaded layout are considered to be a new layout and is only remembered if the new layout is named and saved to become a new layout or named as an existing named layout.
	[image: ]

	[bookmark: _Toc484078990]Figure 4.53 Call Taker SoftPhone Save Layout Option


[bookmark: _Hlk481840313][bookmark: _Hlk481844891][bookmark: _Hlk481844798]Minor modifications (panel resizing, relocating a floating window, column resizing) made to the currently loaded layout are not saved to the named layout. They are remembered by this Call Taker SoftPhone workstation and the next time the application is launched they will be applied onto of the currently loaded named layout. These station specific remembered modifications are cleared whenever a layout is loaded from the Option menu; so create a new named layout if they are modifications of interest, before loading a new layout.
The currently loaded layout, with its minor or major modifications, can be saved using either of these approaches:
· Select Options > Layout > Save to update the currently loaded named layout
· Select Options > Layout > Save As to create a new named layout

Note: Layouts are retained in the Call Taker SoftPhone Installation Directory, and are not stored in a shared, central repository for access by other Call Taker SoftPhone workstations. To share a new or modified layout, copy the pair of files with the names “…_layout.xml” and “…_layout_extra.xml”, where “…” represents the name of the layout as seen on the Call Taker SoftPhone Options > Layout > Load Layout dropdown list. 
All Panels available for use may or may not appear on the currently loaded layout. A complete list of Panels can be shown by clicking on the Windows menu option. The list will open, as shown in Figure 4.52:
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	[bookmark: _Ref483666078][bookmark: _Toc484078991]Figure 4.54 Call Taker SoftPhone Windows Menu



To display a panel that is not currently visible, review the complete list of available panels and click on the desired panel. The panel will be made visible in the mode and location it was in, when it was previously hidden in the named layout which is currently loaded.


Panels have several modes which define their behaviour in the Main Window. 
To reveal the list of modes, click on the pull down menu arrow in the right corner of the Title Bar, or right-click on the panel’s Title Bar. The following list of modes will display as shown below in Figure 4.53:
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	[bookmark: _Ref483666145][bookmark: _Toc484078992]Figure 4.55 Call Taker SoftPhone Panel Movement Menu



A description of each panel mode is listed below:
· Floating – Makes docked panel a floating window
· Dockable – Allows floating window to be docked
· Auto-Hide – Converts selected panel into an tab which is placed at either the left, right, top or bottom of the Main Window. The placement is based on the proximity to the four (4) noted locations. The auto-hide tab has the name of the panel as its tab name. The tab, when hovered over with the cursor or clicked, displays the panel for use. Clicking outside of the panel will cause the panel to be hidden.
· Hide – Hides selected panel and remembers whether it was floating or docked and its location in the Main Window

[bookmark: _Hlk481849611][bookmark: _Hlk481849269]To dock a floating window left click on the title bar and continue to hold down the left mouse button. Then drag the panel over the docked panel which it will be adjacent or tabbed into. A crosshair pattern (shown in Figure 4.53) will appear that is to be used to indicate the desired docking position relative to the already docked panel. 
To move an already docked panel, left click on the title bar and continue to hold down the left mouse button Then drag the panel away from its docked location. The panel can be left floating or be docked by dragging it over the docked panel which it will be adjacent or tabbed into. A crosshair pattern (shown in Figure 4.54) will appear that is to be used to indicate the desired docking position relative to the already docked panel. 
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	[bookmark: _Ref483666200][bookmark: _Toc484078993]Figure 4.56 Call Taker SoftPhone Crosshair Pattern



To complete the docking process, while continuing to hold down the left mouse button, move the pointer over the specific crosshair directional image (up, down, left, right, or center) and release the left mouse button to choose the panel’s dock position. Choosing the center of the crosshair will create a nested tab within the existing panel space. Choosing one of the arrows will dock the panel above, below, left or right of the existing docked panel, within the existing panel space. 
To resize an existing docked panel, move the pointer over the top, bottom, left or right panel border until the resizing pointer is displayed. While continuing to hold the left mouse button, move the border in the desired direction. Release the left mouse button to set the new border in place. 
Note: Resizing a panel typically affects adjacent panel sizes, which may not appear as desired. Control+Z and Control+Y are available to undo and redo modifications. 

[bookmark: _Toc484079051]Customizing Layout Colors
The Call Taker SoftPhone application has a Color Theme Customization feature that allows the user to completely customize the colors of the Main Window, Panels and text they see while using the application. The default color scheme at installation is the current Microsoft Windows theme, but the color of most backgrounds, alerts, and text can be configured to suit the preference of the user. Each time the application exits, the current layout configuration is remembered and used when the application is relaunched. The remembered layout includes any current color settings, which are the result of a loaded Color Theme or color modifications added after loading a Color Theme. 
	[image: ]

	[bookmark: _Ref483854507][bookmark: _Toc484078994]Figure 4.57 Call Taker SoftPhone Color Theme Menu


After selecting Color Theme from the Options menu, the secondary menu choices are Load, Edit and Reset. A description of these options is included below:
· Load – This menu may include a choice of pre-selected color themes (as shown in Figure 4.55), which will take immediate effect on the Main Window and Panels if selected.
· Edit – Selecting this option opens a System Defined Colors panel, which allows the user to create a color scheme based on every aspect of the application. Once the selections have been made, the user has the option to save the selection in the Load menu, and/or apply the selections to the Main Window and Panels immediately.
· Reset – Selecting Reset restores the application to the standard Microsoft Windows color theme.

To modify the current color settings select Options > Color Theme > Edit.  The System Defined Colors panel will open. 
	[image: ]

	[bookmark: _Toc484078995]Figure 4.58 Call Taker SoftPhone System Designed Colors panel



Color selections can be made for a variety of features and forms contained in the application by clicking on the Ellipsis box next to the feature desired. A Color panel shown in Figure 4.57 will open and the user can then select the color desired for the feature selected.
	[image: ]

	[bookmark: _Ref483854569][bookmark: _Toc484078996]Figure 4.59 Call Taker SoftPhone Color Selector



Feature changes can only be made one at a time by clicking on each of the Ellipsis boxes for the each feature change a user desires to make. Color values changes made take immediate effect and are applied to the current layout configuration. The current color settings can be saved through the System Defined Colors panel as a customer named Color Theme using the Save As button. To exit the window, click on the window’s close control button.
Note: Color Theme configurations are saved only on the Call Taker station executing the configuration change, and are not shared across workstations.
To Load a Color Theme into the current layout configuration click on  
Options > Color Theme > Load. 
The list of color themes shown will include those shipped by the manufacturer as well as any customer named color themes added by the user. Click on the desired color theme in order to make the desired color change.
To Reset the Call Taker SoftPhone application to the default Microsoft Window Theme in the current layout configuration select: 
Options > Color Theme > Reset.
The Microsoft Window theme will automatically be applied to the system settings.




[bookmark: _Toc484079052]Greeting Rules 
Greeting Rules is a feature that allows Call Takers to create custom greetings that can be played for incoming callers based on a pre-determined criteria. It is a feature that is enabled by the system Administrator and that allows for more efficient call handling by the Call Taker. 
If the administrator configured the system to play announcements on connect, the Greeting Rules option will be enabled. The Greeting Rules window can be found under the Options menu. To open this window, click on Options > Greeting Rules. The Greeting Rules window will open. 
	[image: ]

	[bookmark: _Toc484078997]Figure 4.60 Call Taker SoftPhone Greeting Rules



	[image: Greeting Rules]

	[bookmark: _Toc484078998]Figure 4.61 Call Taker SoftPhone Greeting Rules Window


A description of the information contained in the table is included below:
· Image – This column contains the image of the lines contained in the workstation
· Line – The name of the lines contained in the workstation
· Station – The number assigned to the workstation
· Size – The size of the recorded file attached to the line
· Description – A description of the recording attached to the line.
Greeting Rules will always have rows for the lines covered within the call center environment where “Line” = “All” and “Station” = “All.” This means that the row that represents the rule can be used by all Call Takers in the environment. These rules, however, cannot be modified by the Call Taker. It can only be set and modified by the Administrator assigned to maintain the system.
Conversely, Greeting Rules will always have rows for the lines covered within the call center environment where “Line” = “All” and “Station” = “the Call Taker’s workstation.” These rules can be modified by the Call Taker.
A Rule is made up of Line and Station attributes. A Rule may or may not have an associated audio file. The Size cell will contain a numeric value if an audio file is present. The Description cell, while optional, could contain a description of the recording attached to the Rule.
Audio files can be added two ways. An audio file can be recorded directly into the system by the System Administrator and/or the Call Taker. System Administrators can create recordings for all lines and all stations within the environment, whereas Call Takers can record audio files for their workstations only. This is done by selecting the Rule that the recording is to be attached to, and clicking on the Record button, clicking Record again when the recording is finished. Adding a Description gives the Call Taker the ability to determine which Rule to use for the incoming calls he/she manages.
An audio file can also be added by importing an existing recording. It is done by clicking on a rule to highlight it, clicking the “Import” button and then going to the file’s location to complete the import. A Description then should be entered so that other users will know what the recording presents. If the same file is imported to multiple rules, the same Description should be entered to clearly note all rules have the same recording.
When a new call arrives and the Call Taker ‘Answers’ the call, the complete set of Greeting Rules could be reviewed to determine if an audio file should be played to the caller rather than answered by the Call Taker.
[bookmark: _Toc484079053]Call Handling
Call handing on the Call Taker SoftPhone is designed to be intuitive, allowing Call Takers to process Emergency calls more efficiently by highlighting the appropriate panels on the Main Screen. The Panels highlighted are based on the type of call coming in, as displayed in the figures below. Call Takers have the ability to then tap or click on the appropriate panel in order to process the call. 
[bookmark: _Toc484079054]Incoming 911 Call
Incoming 911 calls are alerted on the Alerts and Lines panels as shown in Figure 5.1. 
	[image: ]

	[bookmark: _Ref483667710][bookmark: _Toc484078999]Figure 5.1 Call Taker SoftPhone Incoming Call Process



Incoming calls can be answered from either the Line appearance button that is highlighted with a red box in the upper left corner, the Alert window, or the Answer Button in the Controls panel. 
To answer an incoming call, click on the Alert panel, the active Line button, or the Answer button in the Controls panel.
Until the call is answered, fields in the ANI/ALI panel will remain empty.

[bookmark: _Toc484079055]Active 911 Call
During an active 911 call, the Alert panel and the Line Appearance Button will light up in green, indicating the call’s active status, as shown in Figure 5.2. 
	[image: ]

	[bookmark: _Ref483667820][bookmark: _Ref482602624][bookmark: _Toc484079000]Figure 5.2 Call Taker SoftPhone Active 911 Call Process


In addition, the ALI panel displays the location information of the caller.
To end an active 911 call, click on the Alert panel, the active Line button, or the Answer button in the Controls panel.

[bookmark: _Toc484079056]Active TDD Call
During a TDD Call, the Alert panel and the Line Appearance Button will light up in green, indicating the call’s active status, as shown in Figure 5.3. 
	[image: ]

	[bookmark: _Ref483668018][bookmark: _Toc484079001]Figure 5.3 Call Taker SoftPhone Active TDD Call Process


The TDD window shows the call conversation and ALI window shows the location information of the caller.
To end an active TDD call, click on the Alert panel or the active Line button in the Lines panel.



[bookmark: _Toc484079057]Hot Keys
The Call Taker SoftPhone can also be operated using keystrokes. Hot Keys functionality was developed for Call Takers who prefer to use keystrokes to operate the application. The chart in Figure 5.4 is a complete list of commands that can be executed using keystrokes from the station’s keyboard. 
	[image: ]

	[bookmark: _Ref483668121][bookmark: _Toc484079002]Figure 5.4 Call Taker SoftPhone Hot Key Functions




[bookmark: _Toc484079058]Troubleshooting
The following section provides status indicators and troubleshooting for potential Call Taker SoftPhone system issues. Contact your company’s designated   or support personnel for further troubleshooting.
[bookmark: _Toc484079059]Status Indicators in the Ticker Panel
The status indicator on the bottom left of the Ticker Panel shows the readiness of the Call Taker’s workstation. 
	[image: ]

	[bookmark: _Toc484079003]Figure 6.1 Call Taker SoftPhone Status Indicators



[bookmark: _Hlk481750951]During start-up, the workstation’s status indicator will display Loading while it establishes a communications link with the Omni911 Communications Server. The status indicator will then display Ready when the workstation is successfully connected to the Omni911 Communications Server and can receive live calls. If the Ready indicator does not appear, the system could be experiencing a problem related to the configuration and/or operation of the workstation, the server, or the communications network. In this state the application is unable to load properly. Contact your System Administrator or support personnel if the workstation is unable to achieve “Ready” status. 
The status indicator on the bottom right side of the status bar reads “Omni” and is color coded to display the real-time status of the communications link between the Call Taker’s workstation and the Omni911 Communications Server. Green indicates an active link to the server and red indicates the communications link is not working properly. The indicator displays the real-time status of the link, thus it may change from green to red or from red to green at any time during use. A failure in the local area network, or a failure between the Omni911 Communications Server and/or the workstation may cause the link indicator to turn red. If this occurs, contact your company’s designated administrator or support personnel who can diagnose the source of the failure and restore normal operation to the communications link. 

[bookmark: _Call_Taker_User][bookmark: _Toc484079060]Call Taker User Authentication
Call Taker SoftPhone supports the following 3 modes of Call Taker (user) authentication: 
· Windows Logon only 
· Named User Authentication 
· Integrated Windows Security. 

The authentication mode is set within a configuration file on each Call Taker’s computer, while the System Administrator uses the Omni911 Admin Client to manage user associated credentials. 
Below are the user authentication modes and their respective behavior, which is driven by the C:\Omni911 Client\OmniClient.exe.config file’s value for the setting “UserLogonMode”. The Call Taker SoftPhone application’s installation sets the UserLogonMode=0. Mode 1 or 2 can be used with JITC Certification. 
[bookmark: _Toc484079061]Windows Logon Only
UserLogonMode=0
· Application access does not require a named user to be identified.
· User is not presented with a Logon window. 
· The application is accessible to a Window user which has successfully logged onto Windows.

[bookmark: _Toc484079062]Named User Authentication
UserLogonMode=1 
· Application access requires a named Omni User to be identified and authenticated.  
· User is presented with a Logon window. Logon window collects Omni911 User ID and Password, which is sent to Omni Server for authentication. Entered User ID and Password must match those previously entered by the System administrator.

[bookmark: _Toc484079063]Integrated Windows Security
UserLogonMode=2 
· User is not presented with a Logon window. Application collects Windows “domain\user name” which was previously entered when logging onto the computer, which is sent to the Omni Server for authentication.
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